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1. Overview

OPC Logger (Lite Edition) is a free OPC client software to perform OPC tags data
collection and save collected data into CSV file. The Lite Edition is designed for small
or light user data collection application.

The OPC Logger (Lite Edition) has a complex data filtering to prevent the illegal and
invalid OPC tags data to be processed and exported into CSV file accidentally.

Under Lite Edition license, OPC Logger can monitor 10 OPC tags and not support the
multi-instance of OPC server datalogging.

For more information about OPC Logger (Lite Edition) software, refer to the references
section in this user manual or visit our website: http:/flatwareshock.tripod.com
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2. System Requirements

The OPC Logger version 2.90 (Lite Edition) software will run on Windows XP or higher
operating systems.

Minimum Hardware Requirements:

> Intel Pentium-class processor; Pentium 3 or higher processor recommended.
> 512 MB of RAM.

> NET Framework 3.5 or higher version to be installed at your computer.
> 500MB of disk space or above.

> VGA or higher resolution monitor. Super VGA recommended.
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3.1 Installation

To install OPC Logger software, use

installation.

=2 Setup - PLC Logger

=] oS

Windows explorer to browser CD for
“OPCLoggerSetup.exe” and click on it. The wizard wll then guide you through the

Welcome to the PLC Logger Setup
Wizard
Thiz will ingtall PLC Logager wersion 2.90 on yaur camplter.

It iz recommended that you cloze all other applications befare
continLing.

Click Mest o continue, or Cancel to exit Setup.

M et > l[ Cancel
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3.2 Basic software operations

3.2.1 Open OPC Logger Project

OPC Logger project file is designed according to XML file format. So you can
read or edit it by using word processing software.

To open the PLC Logger project, select File > Load project file.

- -
—
& PLC Logger (Main) mE
File | Edit  Action  Abouk
| Load project File
Exit
Disk space: 123,361 MBytes, Min, disk space required : 12,336 MBytes, -
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Select the OPC Logger project (*.xml). All OPC Logger project file is XML file
extension.

-
—
Open PLC logger project
Lok ir: ||.'j\ projects M <) T G-
E - PLCLoggert,xml
{ |Z| PLCLogger2. <
by Recent
Documents
;[‘:
Desktop

)

by Documents

o

My Cornpuiter

-

File name: |F'LEL|:ugger1.:-:mI [ Open \

El[E]

My Network, | Files of bupe: | PLC Logger project [ Cancel ]

After opening OPC Logger project file successfully, OPC Logger engine will
prompt user whether to start OPC server datalogging.

PLC_Logger =

:t,/. Start the OPC datalogging now #

OPC Logger engine will show datalogging information message when all engine
parameters and OPC tags to be monitored are valid and no errors.

i) PLC Logger version 2.90 x

Dratalogging is running.
Target OPC Server: ICOMICS, SimulatorQPCDA, 2

Vel BB NER W s

s
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Below is OPC Logger project example. It contains OPC server details, OPC group
details and OPC tags to be monitored.

ZpLC Logger S ICONICS. SimulatorOPCDA. 2

o

Al T

Fil=  Edit

[=- == Connection
Ih Mame: ICOMICS. SimulatorPCDA, 2
h Mode:
I Actve: True
== Group
El Mame: BoomdCl
R Update rate: 20 ms
R Descrption:
R Active: True
EE Deadband: 0%
OPC tag
B Murmernic._|4
B Textual Mumerals
B Murmernic._|2
[P Logical Square
B TextualWeekdays
2 Textual Caolors
P Mumernic._Cv

IEI-_

Disk. space: 122,965 MBytes,

Min. disk space required : 12,297 MBytes,
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OPC Logger engine must be configured before starting OPC tag data collection.

Select Edit > Configuration.

2 piLC Logger - ICONICS.SimulatorOPCDA. 2

=)o

File | Edit | Ackion  About

- ® & it

#_  Configuration |[|:| CoA.2

E) Mode:

== Group
Bl Mame: AC_room
Bl Update rate; 10 ms
El Descriphion:
Bl Active: True
El Deadband: 0%
== 0OPC tag
[ Murnernic. R andonm
[ Murmenic.ReadCount
[ Murmernic.Square
[ Textualweekdays

Disk space: 122,951 MBwkes,

Min, disk space required : 12,295 MEvtes,

“File location” parameter is disk drive folder to keep the collected data files.

“SQL location” parameter is CSV file source path for Flatdata software

integration.

= pLC Logger - ICONICS.SimulatorOPCDA. 2

/o

About

Datalogging folder

Option

kdin. dizk space : 10 hdbwtes.

Enable minimun dizk space warning

Dizk space available : 122,850 MBytes

File location : | CMfrenkilPLCLoaggerPLC_LoggerbintDebughCEvlag

SOL location : |CMfrenkilPLCLoggerPLC LoggerbiniDebuglSallog

L]

Disk space; 122,950 MBykes,

Min, disk space required : 12,295 MBvtes,
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The OPC Logger engine has an option to notify user whenever disk space is
getting lower than the required disk space.

To use disk space monitoring option, you just check on “Enable minimun
disk space warning”

Click on “Apply” button to activate the new OPC Logger configuration.
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Select Edit > OPC Tag Browser.

Epic Logger - ICONICS.SimulatorOPCDA. 2

BE %)

File | Edit | Action  Abouk

= [ | CPC Tag Brawser
=

- ‘ Canfiguration IPCOA. 2

_—E) Mode:
I Active: True
== Group
[l Mame: RoomalCl
[l Update rate: 20 me
[l Description:
[l Active: True
El Deadband 0%
== OPCtag
% Mumernic._|4
I Testual Mumeralz
% Mumernic._|2
% Logical Square
I TestualWeekdays
% Textual Colars
% Mumernic._Cv

Disk space: 122,958 MBytes,

Min. disk space required : 12,296 MBytes,

The OPC Tag browser is used to view OPC tags that are being connected to
OPC server and to set the OPC tags update rate, etc.
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Click on Refresh button to update the OPC servers that are being installed.

Once OPC Logger engine detects OPC servers, then OPC servers' name

will be listed.

£ opc Tag Browser

QPC Server Add OPC Group
ACONICS SimulatorOPCDA 2 ;I\Eefresh (i Hzme Croupl
e Upciate Rate (ms) |1
Deadband (%) ]
Mode Mame Group Active

Select the OPC server in the list. Click on Connect button to establish
OPC Logger engine and OPC server data connection.

Enter OPC group name, update rate (ms), then click “Add Group” button to

insert the OPC server group.

= opc Tag Browser

OPC Server

Dizconnect

Acdd QOPC Group

Group Mame
Updste Rate (m=.)

Desdband (9%

_14

_Rd
It
temary
Famp

: FeadCaunt
[

Sguare

[

OPC Tag selected :

Tag: O

Close
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After inserting OPC server group, you can start to browse and insert the OPC tags
into OPC Logger engine.

Select OPC tag tree folder and double-click on OPC tag in the list. The OPC tag
will be added into OPC Logger engine automatically.

-
& opc Tag Browser
CPC Server Add OPC Group
Group Name
Update Rate (ms.)

Deadhand (%)

frenki Colors
aio il tMemony
Maonths
I Mumerals

i YWieekdays

QPC Tag selected

Mumeric.Random
Murmetic ReadCount
Murnetic.Souars
extual Weekdays

Tag: 4

Click on Apply button to add the selected OPC tags and start the OPC tag
datalogging.
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PLC logger o

,jr,i PLC Logger version 2.90
?/ Do yiou wank bo skark OPC dakalogging now #

- Datalogaging is Funning.

Target OPC Server: ICOMICS, SimulatorOPCDA, 2

SLBEEAS %S @ s4eqrm

| fes | [ Mo ] 2 -1

Click on Yes button to continue the OPC tag datalogging.

IMPORTANT :

1. Please take note that OPC Logger (Lite Edition) can monitor up to 10
OPC tags only.

2. OPC Logger (Lite Edition) does not support multi-instance datalogging.

3. For more information about OPC Logger software, please visit Flatware
Company's website: www.flatwareshock.tripod.com
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3.2.4 Start OPC Logger
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Select Action > Start to start OPC Logger engine to collect the OPC server tags.

Eric Logger - ICONICS. SimulatorOPCDA. 2

S|E¥

File  Edit | #ction | &bout
= @BPES p star
== Co
I latarOPCDA, 2
b Mode:
b Active: True
[ ™= Group

El Mamme: RoomaCl

El Update rate: 20 ms

El Description:

El Active: True

El Deadband: 0 %
(== OPCtag

% Mumeric._14

% Tewtual Mumneralz

% Mumeric._|2

[P Logical Square

% Tewtual Weekdays

% Tewtual Colors

% Mumenic._CY

Disk space: 122,955 MBvtes.

Min. disk space required ; 12,296 MBytes,

OPC Logger engine can be started via system icon tray.

Right-click on on OPC Logger icon in the system tray, then select

“Action > Start”

&  show Interface

Action

Ahauk

Exit
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3.2.5 Stop OPC Logger
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Select “Action > Stop” to stop OPC Logger engine.

Z pLC Logger - ICONICS. SimulatorOPCDA.2

ME X

File  Edit | Acktion | Abouk

- @EEEE > |
== Coll g
o Stop
H Mode:
B Active: True
(=)= GGroup
R Mame: RoomaCl
R Update rate: 20 mz
R Descrption:
R Active: True
R Deadband: 0%
OPC tag
% Murnernic._[4
% Textual Mumerals
% Murmernic._[2
% Logical Square
% Testualweekdays
% Tedtual Colors
% Murnernic._CY

Lulatcurl:l PCDA 2

IEI-.

Disk space: 122,963 MBytes,

rin. disk space required : 12,296 MBytes,

Click on Yes button to continue.

PLC_Logger

\_:.i) Stop the OPC datalogaging 7

[ Hes | [ W

=

A1) PLC Logger version 2.90
Datalogging is skopped by user,

SLBaBe %S
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3.2.6  Upgrade OPC Logger to Professional Edition

OPC Logger (Lite Edition) can be upgraded to Professional Edition
which support multi-instance datalogging and total OPC tags can be added
is up to 100 tags.

Select “About > Upgrade software”

B PLC Logger (Main) M=
File  Edit  Ackion | Abook

& Software version

License agreement

Gfl Developer website
|f| Check. product updates

Email bechnical support beam

Upgrade software

Disk space: 121,733 MEytes, Min, disk space required : 12,173 MBytes,
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In Upgrade window, there is a software ID of OPC Logger that is being
installed at your computer system.

Please write down this software ID and email it to Flatware Company's
technical support team.

Upon software verification process, Flatware Company will email you
the Upgrade Code to upgrade your software.

-,

ZpLC Logger - Upgrade your software.

Flatware PLC Logger version 2.90
Always so stmple (Lite Edition)

doftware ID : 73648190 §3iC0S4M3ZER

Tpgrade code @

Note: Please email "Software ID™ to Flatware Company

Lo geherate your upgrade code,

IMPORTANT :
1. OPC Logger (Professional Edition) is not a freeware.

2. Please contact Flatware Company for more information.
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4. Integrate with FlatData DB conversion

FlatData software is a database conversion tool. It will import CSV data into

MS-Access database.

To integrate OPC Logger software with FlatData, we must configure :

4.1. “SQL location” in OPC Logger software. It is disk drive path to keep

CSV files.

B PLC Logger - ICONICS.SimulatorOPCDA. 2 (=)

About

Dratalogging folder

||

e

Ciption
tdin. dizk space : 10/ hdbytes.
Enable minimun disk space warning

Dizk space available : 122 850 hBytes

File location : | CifrenkilPLCLoggeriFLC LoggenbiniDebuglCSWlog

Sl |ocatio®knmcmggeru='|_c_|_oggerxbintoebugxsol_l_og (]

Apply ]

[ e ]

Disk space: 172,950 MBytes.

Min. disk space required : 12,785 MBytes.

4.2. “CSV file source path” in Flatdata software.

Flatdata engine will browse the CSV file in disk drive path (as configured in
“CSV file path” field). When CSV files are arrived at disk drive path, then
Flatdata engine will open CSV file, then retrieve & validate the CSV data

before exporting into database.

(Y Flatdata - Configuration

Database -Access | TSV setting

After exporting CSY file to database :

O Delete C5V file.

:/:VVCS\/ file path . |Chcsw

Backup falder : C:“:bckCS\f

@& Mawve CBY file to backup falder.

Apply ] l

LCancel
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5. References

LICENSE AGREEMENT

Copyright (C) 2004-2009 Flatware Company, All right reserved.

Author: Flatware Company & BAD Associates.

Email: lim_frenki@yahoo.co.uk

Distribution Policy:

All OPC Logger software, data, source and documentation files are copyright —

reserved free software. You may use, copy and distribute it free of charge under the
following conditions:

1. Never change the copyright statement.

2. The OPC Logger software must be distributed in absolutely unmodified
form, including all program, data, source and documentation files.

If you distribute OPC Logger to friends, associates, ftp or web sites, CD-ROM

publishers, or to computer bulletin board systems (BBS), be sure to distribute
it entirely and unchanged.

3. OPC Logger software must not be sold for profit. No charge or payment may be
levied or accepted for it.

4. OPC Logger software may be distributed with other free or commercial products
(i.e. software, books, evaluation boards), if it is no functional part of these

products, and without extra cost. Do not distribute OPC Logger together with
protected software.

5. All source files provided with the OPC Logger package may be modified for

personal use, but not redistributed. Changes that may be of general interest
should be sent to the authors.

6. This notice may not be removed or altered from any OPC Logger software
distribution.

7. Exceptions are only possible with a written permission of the authors.
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Disclaimer:

This software is provided as it is, without warranty of any kind, expressed or
implied, including but not limited to the implied warranties of merchantability
and fitness for a particular purpose.

The person using the software bears all risk as to the quality and performance of
the software. The authors will not be liable for any special, incidental,
consequential, indirect or similar damages due to loss of data, time or profit or any
other reason, even if the author or an agent of the author has been advised of the
possibility of such damages.

OPC Logger software, data and documentations are subject to change without prior
notice.

OPC Logger is a trademark of: Flatware Company.
SQL 1s a trademark of: Microsoft Corporation.
MS Access is a trademark of: Microsoft Corporation.

Flativrare The Flatware Company

Always so stuple Website: http://flatwareshock.tripod.com

Technical support email : lim_frenki@yahoo.co.uk
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